3.2. 隨版本演進的軟體變更

下面將詳細介紹隨版本演進而變更的個別項目。這份摘要內容會說明,例如基本設定是否已完全重新設定、組態檔是否已移至他處,或者一般應用程式是否有大幅變更。這裡也會介紹影響到使用者階層、或管理者階層之日常系統使用的大幅度修改。

個別版本的問題和特殊討論,都會在個別點出時提供線上內容。請參閱下列連結。個別套件的重要更新可使用 YaST 線上更新 (YOU),從 http://www.novell.com/products/linuxprofessional/downloads/ 下載取得 -- 請參閱節 2.3.3, "線上更新軟體" (↑啟動)

3.2.1. 從 9.0 到 9.1

請造訪位在 http://portal.suse.com 的 SUSE 支援資料庫,使用關鍵字特殊功能 (special features),找出並參閱「SUSE LINUX 9.1 中的已知問題及特殊功能 (Known Problems and Special Features in SUSE Linux 9.1)」這篇文件。這些文件都是依據每個 SUSE Linux 版本編寫發佈。

3.2.1.1. 升級成核心 2.6

SUSE Linux 現在已完全根據核心 2.6 完成建置。因為其中封裝的應用程式不適用於核心 2.4,因此您不能再使用先前的 2.4 版。請記下下列詳細資料:

  • 模組載入是使用 /etc/modprobe.conf 檔來進行設定。檔案 /etc/modules.conf 已過時。YaST 會嘗試轉換檔案 (另請參閱程序檔 /sbin/generate-modprobe.conf)。

  • 這些模組的字尾為 .ko

  • 燒錄 CD 已不再需要用到模組 ide-scsi

  • ALSA 音效模組選項已經移除字首 snd_

  • sysfs 現在使整個 /proc 檔案系統更臻完善。

  • 電源管理 (特別是 ACPI) 比以前更為進步,而且可以使用 YaST 模組來加以設定。

3.2.1.2. 裝載 VFAT 分割區

裝載 VFAT 分割區時,參數 code 必須變更為 codepage。如果您無法裝載 VFAT 分割區,請檢查檔案 /etc/fstab 是否含有舊的參數名稱。

3.2.1.3. 使用 ACPI 待命及暫停

核心 2.6 支援使用 ACPI 來執行待命及暫停。此項功能仍在實驗階段,因此可能不受某些硬體元件支援。若要使用此功能,您必須使用 powersave 套件。如需此套件的相關資訊,請參閱 /usr/share/doc/packages/powersavekpowersave 套件會提供圖形化前端介面。

3.2.1.4. 輸入設備

關於輸入設備連線的變更,請參閱前述入口網站文件「SUSE LINUX 9.1 中的已知問題及特殊功能」;請造訪位於 http://portal.suse.com 的「支援資料庫」,使用關鍵字特殊功能找出這份文件。

3.2.1.5. 原始 POSIX 執行緒程式庫和 glibc 2.3.x

根據 NGPT (「新一代的 POSIX 執行緒」) 連結的應用程式不能配合 glibc 2.3.x 使用。所有不是由 SUSE Linux 隨附而會受到影響的應用程式,都必須使用 linuxthreads 或 NPTL (原始 POSIX 執行緒程式庫) 進行編譯。NPTL 是較好的選擇,因為它是未來的標準。

如果 NPTL 執行發生問題,請設定下列環境變數來使用較早版本的 linuxthreads 實作 (請將 kernel-version 取代成個別核心的版本編號):

LD_ASSUME_KERNEL=kernel-version

下面是可能的版本編號:

2.2.5 (i386, i586):

沒有浮動堆疊的 linuxthreads

2.4.1 (AMD64、IPF、s390x、i586、i686):, 2.4.1 (AMD64、i586、i686):

有浮動堆疊的 linuxthread

關於核心和有浮動堆疊的 linuxthreads 的注意事項:使用 errnoh_errno_res 的應用程式必須使用 #include 來包含標頭檔 (errno.hnetdb.hresolv.h)。如果是包含使用執行緒取消多執行緒支援的 C++ 程式,就必須利用其環境變數 LD_ASSUME_KERNEL=2.4.1 來提示使用 linuxthreads 程式庫。

3.2.1.6. 原始 POSIX 執行緒程式庫的調整項目

SUSE Linux 9.1 已包含 NPTL 作為執行緒套件。NPTL 是二進位格式,因此相容於舊版的 linuxthreads 程式庫。不過,發生 linuxthreads 違反 POSIX 標準的所有區域都必須調整 NPTL。這個調整動作包括下列項目:訊號處理、傳回所有執行緒所包括相同值的 getpid,以及當 vfork 使用時就無法透過 pthread_atfork 來登錄執行緒處理常式。

3.2.1.7. 網路介面組態

網路介面組態已經變更。過去在設定不存在介面之後,硬體就可完成啟始化。如今,系統會搜尋新硬體並立即予以啟始化,以便啟用新網路介面的組態。

這樣就可在組態檔案中導入新名稱。由於網路介面的名稱會動態產生,而且熱插拔 (HotPlug) 設備的使用也逐漸增加,因此類似 eth0eth1 等名稱已不再適用於組態設定。因此,命名介面組態時會使用唯一專屬的指定資訊,例如 MAC 位址或 PCI 插槽。您可以在介面名稱一出現時,立即使用該介面。您仍可以繼續使用例如 ifup eth0ifdown eth0 等指令。

設備組態位於 /etc/sysconfig/hardware。這些設備所指定的介面通常會出現在 /etc/sysconfig/network (有不同名稱)。如需詳細資訊,請參閱 /usr/share/doc/packages/sysconfig/README

3.2.1.8. 音效組態

完成更新之後,音效卡就必須重新設定。您可以使用 YaST 音效模組來完成此工作。以 root 身份輸入 /sbin/yast2 sound

3.2.1.9. 以頂層領域 .local 作為「連結-本地」領域

解析程式庫會將頂層領域 .local 視為「連結-本地」領域,並將多重廣播 DNS 查詢傳送至多重廣播位址 224.0.0.251、連接埠 5353,而不用一般的 DNS 查詢。這是一個不相容的變更。如果領域 .local 已用於名稱伺服器組態,請使用別的領域名稱。如需有關多重廣播 DNS 的詳細資訊,請造訪 http://www.multicastdns.org

3.2.1.10. 全系統 UTF-8 編碼

此系統的預設編碼為 UTF-8。因此在執行標準安裝時,會以 UTF-8 編碼來進行地區設定,例如 en_US.UTF-8。如需更多資訊,請參閱 http://www.suse.de/~mfabian/suse-cjk/locales.html

3.2.1.11. 將檔名轉換為 UTF-8

先前建立檔案系統中的檔案,並不是使用 UTF-8 編碼來為檔案命名 (除非另有規定)。如果這些檔名含有非 ASCII 字元,將成為亂碼。若要加以更正,請使用 convmv 程序檔來將檔名編碼轉換為 UTF-8。

3.2.1.12. 與 2001 POSIX 標準相容的外圍程序工具

在預設狀態下,coreutils 套件中的外圍程序工具 (tailchownheadsort等等) 不再與 1992 的 POSIX 標準相容,而是與 2001 的 POSIX 標準相容 (單一 UNIX 規格,版本 3 == IEEE Std 1003.1-2001 == ISO/IEC 9945:2002)。使用環境變數可強制執行較舊版本的作業。

_POSIX2_VERSION=199209

新值為 200112,並且用來做為 _POSIX2_VERSION 的預設值。您可造訪 http://www.unix.org 來檢視 SUS 標準 (免費但必須註冊) 。

[Tip]提示

協力廠商軟體可能還無法與新標準相容。因此,請依照上述步驟來設定環境變數。

3.2.1.13. 過時的 /etc/gshadow

由於下列原因,/etc/gshadow 已成為多餘,因此被放棄並移除:

  • glibc 已不再予以支援。

  • 此檔案沒有正式的介面。甚至陰影套裝軟體中也沒有此介面。

  • 用來檢查群組密碼的工具大多不支援此檔案,並因此加以忽略。

3.2.1.14. OpenLDAP

由於資料庫的格式已變更,因此需要重新產生資料庫。在更新時,系統會試著自動執行此轉換工作。不過,當然會出現轉換失敗的狀況。

配置檢查已有長足的進步。因此,許多不符合標準的作業,之前還可能用於 LDAP 伺服器,如今已不再適用。

為了檢視 ACL,組態檔案的語法已做了部分變更。安裝好之後,可在檔案 /usr/share/doc/packages/openldap2/README.update 中找到有關更新的資訊。

3.2.1.15. 以 Apache 2 取代 Apache 1.3

Apache 網頁伺服器 (版本 1.3) 已被 Apache 2 取代。有關版本 2.0 的詳細文件資訊可在網頁 http://httpd.apache.org/docs-2.0/en/ 中找到。在包含 HTTP 伺服器安裝的系統上,更新動作會移除 Apache 套件並安裝 Apache 2。因此,該系統必須以 YaST 或手動進行調整。在 /etc/httpd 中的組態檔案現在已移到 /etc/apache2 中。

同時處理多個查詢時可以選擇執行緒或程序。程序管理已移到一個獨立的模組,即多重處理模組 (Multiprocessing Module,MPM)。據此,Apache 2 需要 apache2-prefork 套件 (建議使用,以提高穩定性) 或 apache2-worker 套件。根據不同的 MPM,Apache 2 會以不同的方式回應查詢。這會影響其效能及模組的使用。這些特點於節 26.4.4, "多重處理模組"中均有詳述。

Apache 2 現在已能支援新一代網際網路協定 IPv6。

目前已執行一項機制,讓模組程式設計人員可指定所要的模組載入程序,除去使用者的負擔。模組執行的順序通常十分重要。在早期的版本中,這個順序是由載入順序所決定。例如,必須先載入一個只允許通過驗證的使用者存取某些資源的模組,以防止無存取許可權的使用者閱讀網頁。

傳至 Apache 的查詢和其發出的回應,都可採用過濾器來處理。

3.2.1.16. 從 Samba 2.x 至 Samba 3.x

將 Samba 2.x 更新為 Samba 3.x 之後,就不能再使用 winbind 驗證。其它驗證方式則可繼續使用。根據上述說明,目前版本已移除下列程式:

/usr/sbin/wb_auth
/usr/sbin/wb_ntlmauth
/usr/sbin/wb_info_group.pl

另請參閱 http://www.squid-cache.org/Doc/FAQ/FAQ-23.html#ss23.5

3.2.1.17. OpenSSH 更新 (版本 3.8p1)

gssapi 支援已由 gssapi-with-mic 取代,以便防止可能的 MITM 攻擊。這兩個版本不相容。這表示您無法以較早版本的 Kerberos 票證來進行驗證,因為已使用其它驗證方式。

3.2.1.18. SSH 與終端應用程式

從遠端主機 (特別是透過 SSH、telnet 和 RSH) 建立版本 9 (含有作用中的 UTF-8 的標準組態) 與較早系統 (SUSE Linux 9.0 及較早版本,其 UTF-8 依照預設為非作用中或不受支援) 之間的連線時,終端應用程式可能會顯示錯誤字元。

這是由於 OpenSSH 未轉送本地設定所致。因此使用了可能不符合遠端終端設定的系統預設值。這會影響 YaST 的文字模式以及遠端主機以一般使用者身份 (而非 root) 所執行的應用程式。以 root 的身份啟動的應用程式只有在使用者變更標準地區設定為 root 時才會受到影響 (只有 LC_CTYPE 是依照預設值來設定)。

3.2.1.19. 捨棄 libiodbc

FreeRADIUS 的使用者現在必須連線至 unixODBC,因為 libiodbc 已被捨棄。

3.2.1.20. /usr/share/xml 中的 XML 資源

XML 資源 (DTD、樣式表等等) 會安裝於 /usr/share/xml。因此,某些目錄已經不存在於 /usr/share/sgml。如果您發現問題,請修改您的程序檔和 makefiles 或使用正式的目錄 (特別是 /etc/xml/catalog/etc/sgml/catalog)。

3.2.1.21. 抽取式媒體與 subfs

抽取式媒體現在已與 subfs 整合。不再需要以 mount 手動裝載媒體。如果要裝載媒體,只要直接在 /media 中變更個別設備即可。如果程式正在使用媒體,則無法將媒體退出。

3.2.2. 從 9.1 到 9.2

請參閱「SUSE LINUX 9.2 中的已知問題及特殊功能」,請造訪位於 http://portal.suse.com 的「支援資料庫」,使用關鍵字特殊功能找出這篇文件。

3.2.2.1. 在安裝時於提議對話方塊中啟動防火牆

為了提高安全性,系統會在提議對話方塊中的安裝結束時,啟動附帶的防火牆解決方案 SUSEFirewall2。這表示一開始時所有連接埠都已關閉,而且可以需要時從提議對話方塊開啟。依照預設,您無法從遠端系統登入。這也會干擾網路瀏覽及多重廣播應用程式,像是 SLP 及 (網路上的芳鄰),以及一些遊戲。您可以使用 YaST 來微調防火牆的設定。

如果在安裝時或設定服務時需要存取網路,則個別的 YaST 模組會開啟所有內部及外部介面所需的 TCP 和 UDP 埠。不需要時,使用者可關閉 YaST 模組中的連接埠或指定其它詳細的防火牆設定。

3.2.2.2. KDE 和 IPv6 支援

依照預設,KDE 並未啟用 IPv6 支援。您可以使用 YaST 的 /etc/sysconfig 編輯器來啟用它。停用這個功能的原因,是因為不是所有的網際網路服務提供者都支援 IPv6 位址,所以可能會造成瀏覽網頁時出現錯誤訊息,以及網頁的顯示出現延遲現象。

3.2.2.3. YaST 線上更新與 Delta 套件

YaST 線上更新現在支援特別的 RPM 套件,此套件僅會儲存指定基本套件的二進位變更。這項技術大幅地降低了套件大小,以及最後重新組合需要用到較多 CPU 的下載時間。您可以在 /etc/sysconfig/onlineupdate 中設定 YOU 是否要使用這些 delta 套件。如需技術詳細資訊,請參閱 /usr/share/doc/packages/deltarpm/README

3.2.2.4. 列印系統組態

在安裝結束前 (提議對話方塊) 必須在防火牆組態中打開列印系統所需的連接埠。CUPS 需要連接埠 631/TCP 和連接埠 631/UDP,而且不應將其關閉,以維持正常作業。連接埠 515/TCP (用於舊的 LPD 協定) 和 Samba 所使用的連接埠也都必須開啟,以透過 LPD 或 SMB 來列印。

3.2.2.5. 變更為 X.Org

XFree86X.Org 的變更是由相容連結來進行,透過該連結可使用舊名稱來存取重要的檔案和指令。

表格 3.1. 指令

XFree86

X.Org

XFree86

Xorg

xf86config

xorgconfig

xf86cfg

xorgcfg

表格 3.2. /var/log 中的記錄檔

XFree86

X.Org

XFree86.0.log

Xorg.0.log

XFree86.0.log.old

Xorg.0.log.old

在變更為 X.Org 的過程中,XFree86* 套件會被重新命名為 xorg-x11*

3.2.2.6. X11 的終端機模擬器

我們已移除一些終端機模擬器,因為它們已不再提供維護,或是已無法在預設環境中使用,尤其是不支援 UTF-8。SUSE Linux 提供標準終端機,像是 xterm、KDE 及 GNOME 終端機,以及 mlterm (X 的多語系終端機模擬器),這個終端機可以用來取代 aterm 與 eterm。

3.2.2.7. powersave 套件中的變更

/etc/sysconfig/powersave 中的組態檔案已變更:

表格 3.3. 分割 /etc/sysconfig/powersave 中的組態檔案

舊的

現在已分割為

/etc/sysconfig/powersave/common

common

cpufreq

events

battery

sleep

thermal

/etc/powersave.conf 已經過時。現有的變數已移至 表格 3.3, "分割 /etc/sysconfig/powersave 中的組態檔案" 中所列的檔案。如果您變更了 /etc/powersave.conf 中的「事件」變數,則現在必須在 /etc/sysconfig/powersave/events 中進行相同的變更。

下列睡眠狀態名稱已經變更:

  • 暫停 (ACPI S4, APM 暫停)

  • 待命 (ACPI S3、APM 待命)

成為:

  • 暫停寫入到磁碟 (ACPI S4, APM 暫停)

  • 暫停寫入到 RAM (ACPI S3, APM 暫停)

  • 待命 (ACPI S1、APM 待命)

3.2.2.8. OpenOffice.org (OOo)

目錄:

OOo 現在安裝於 /usr/lib/ooo-1.1 而非 /opt/OpenOffice.org。使用者設定的預設目錄現在為 ~/.ooo-1.1 而非 ~/OpenOffice.org1.1

包裝函式:

有一些新的包裝函式可用來啟動 OOo 元件。表格 3.4, "包裝函式" 會列出這些新名稱。

表格 3.4. 包裝函式

舊的

新的

/usr/X11R6/bin/OOo-calc

/usr/bin/oocalc

/usr/X11R6/bin/OOo-draw

/usr/bin/oodraw

/usr/X11R6/bin/OOo-impress

/usr/bin/ooimpress

/usr/X11R6/bin/OOo-math

/usr/bin/oomath

/usr/X11R6/bin/OOo-padmin

/usr/sbin/oopadmin

/usr/X11R6/bin/OOo-setup

/usr/X11R6/bin/OOo-template

/usr/bin/oofromtemplate

/usr/X11R6/bin/OOo-web

/usr/bin/ooweb

/usr/X11R6/bin/OOo-writer

/usr/bin/oowriter

/usr/X11R6/bin/OOo

/usr/bin/ooffice

/usr/X11R6/bin/OOo-wrapper

/usr/bin/ooo-wrapper

包裝函式現在支援選項 --icons-set,因此可在 KDE 和 GNOME 圖示之間切換。下列選項已不再受到支援:--default-configuration--gui--java-path--skip-check--lang (其語言現在是由地區設定來決定)、--messages-in-window--quiet

KDE 和 GNOME 支援:

可在 OpenOffice_org-kdeOpenOffice_org-gnome 套件中找到 KDE 和 GNOME 的副檔名。

3.2.2.9. 混音器 kmix

已預先將混音器 kmix 設定為預設項目。對於高階硬體,有其他的混音器,如 QAMix。KAMix、envy24control (僅限 ICE1712) 或 hdspmixer (僅限 RME Hammerfall)。

3.2.2.10. DVD 燒錄

過去我們會從 cdrecord 套件將修補程式套用到 cdrecord 二進位檔案,以便支援燒錄 DVD。現在,新安裝的二進位檔案 cdrecord-dvd 本身會包含這個修補程式。

dvd+rw-tools 套件的 growisofs 程式現在可以燒錄所有的 DVD 媒體 (DVD+R、DVD-R、DVD+RW、DVD-RW、DVD+RL)。建議您使用此程式,取代套用修補程式的 cdrecord-dvd

3.2.2.11. 多核心

現在您可以同時安裝多個核心。這個功能是指,允許管理員透過安裝新核心來從一個核心升級到另一個核心,接著驗證新核心可以如預期般正常運作,然後再解除安裝舊核心。在 YaST 不支援這項功能時,使用 rpm -ipackage.rpm 指令便可輕易地從外圍程序安裝核心或解除安裝核心。

預設的開機載入器功能表包含一個核心項目。在安裝多個核心之前,您可以為額外的核心新增一個項目,以方便您選取這些核心。在安裝新核心之前啟動的核心,可以依 vmlinuz.previousinitrd.previous 方式存取。透過建立與預設項目相似的開機載入器項目,並讓這個項目從參照 vmlinuzinitrd,改成參照 vmlinuz.previousinitrd.previous,就可以存取之前啟動的核心。此外,GRUB 與 LILO 支援萬用字元開機載入器項目。請參閱 GRUB 資訊頁面 (info grub) 以及 lilo.conf(5) 手冊頁,以取得詳細資訊。

3.2.3. 從 9.2 到 9.3

請參閱「SUSE LINUX 9.3 中的已知問題及特殊功能」這篇文件,請造訪位於 http://portal.suse.com 的「支援資料庫」,使用關鍵字特殊功能來找出這份文件。

3.2.3.1. 在核心提示啟動手動安裝

開機載入器畫面已不再提供手動安裝模式。您仍然能夠在開機提示中使用 manual=1,讓 linuxrc 進入手動模式。通常這不是必要的,因為您可以直接在核心提示中設定安裝選項,像是 textmode=1,或是設定一個 URL 做為安裝來源。

3.2.3.2. 網路驗證的 Kerberos

Kerberos 取代 heimdal,成為預設的網路驗證。無法自動轉換現有的 heimdal 組態。系統更新組態檔案的備份時,會建立 表格 3.5, "備份檔案" 中顯示的項目。

表格 3.5. 備份檔案

舊的檔案

備份檔案

/etc/krb5.conf

/etc/krb5.conf.heimdal

/etc/krb5.keytab

/etc/krb5.keytab.heimdal

用戶端組態 (/etc/krb5.conf) 和 heimdal 的組態十分相似。若無特別設定,用 admin_server 來替換參數 kpasswd_server 就可以了。

您無法複製伺服器相關 (kdc 和 kadmind) 資料。在更新系統後,仍可在 /var/heimdal 下取得舊的 heimdal 資料庫。MIT kerberos 會在 /var/lib/kerberos/krb5kdc 下維護此資料庫。

3.2.3.3. JFS:不再支援

由於 JFS 的技術問題,所以不再支援 JFS。核心檔案系統驅動程式還在,只是 YaST 不提供使用 JFS 進行硬碟分割。

3.2.3.4. AIDE 做為 Tripwire 替代品

如需入侵偵測系統,請使用 GPL 所發行的 AIDE (套件名稱為 aide)。SUSE Linux 中已沒有 Tripwire。

3.2.3.5. X.Org 組態檔案

組態工具 SaX2 可將 X.Org 組態設定寫入 /etc/X11/xorg.conf。在重頭安裝時,並不會建立任何從 XF86Configxorg.conf 的相容連結。

3.2.3.6. 刪除 XView 和 OpenLook 支援

捨棄套件 xviewxview-develxview-devel-examplesolvwmxtoolpl。在過去,我們只提供 XView (OpenLook) 基本系統。系統更新之後,我們不再提供 XView 程式庫。更重要的,無法再使用 OLVWM (OpenLook Virtual Window Manager,OpenLook 虛擬視窗管理員)。

3.2.3.7. PAM 組態

新的組態檔案 (包含註解提供更多資訊)

common-auth

Auth 區段的預設 PAM 組態

common-account

帳戶區段的預設 PAM 組態

common-password

密碼變更的預設 PAM 組態

common-session

工作階段管理的預設 PAM 組態

您應該在應用程式特殊組態檔案中加入這些預設組態檔案,因為與修改、維護將近四十個在系統中常見的檔案相比,僅修改和維護一個組態檔是要容易多了。若您之後再安裝一個應用程式,此應用程式會繼承已套用的變更,管理員不需要費事去調整其組態。

這個變更很簡單。若您有下列組態檔 (大多數的應用程式預設會有這些檔案):

#%PAM-1.0
auth     required       pam_unix2.so
account  required       pam_unix2.so
password required       pam_pwcheck.so
password required       pam_unix2.so    use_first_pass use_authtok
#password required      pam_make.so     /var/yp
session required        pam_unix2.so

您可以將它變更成:

#%PAM-1.0
auth     include        common-auth
account  include        common-account
password include        common-password
session  include        common-session

3.2.3.8. 較嚴格的 tar 語法

新的 tar 使用語法較為嚴格。tar 選項必須放在指定檔案或目錄的前面。將選項 (例如 --atime-preserve--numeric-owner) 附加在指定的檔案或目錄之後,則 tar 指令會失敗。請檢查您的備份程序檔。下列指令已經無法運作:

tar czf etc.tar.gz /etc --atime-preserve

如需詳細資訊,請參閱 tar info 頁面。

3.2.4. 從 9.3 到 10.0

請參閱「SUSE LINUX 10 中的已知問題及特殊功能」這篇文件,請造訪位於 http://portal.suse.com 的「支援資料庫」,使用關鍵字特殊功能來找出這份文件。

3.2.4.1. 使用 su 指令成為超級使用者

依照預設,呼叫 su 以成為 root 使用者,並不會設定 rootPATH。請呼叫 su -,以 root 的完整環境啟動登入外圍程序,或若您希望變更 su 的預設行為的話,請在 /etc/default/su 中將 ALWAYS_SET_PATH 設定為

3.2.4.2. 省電組態變數

省電組態變數的名稱已變更以達一致性,但 sysconfig 檔案仍然相同。如需更多詳細資訊,請參閱節 33.5.1, "設定 powersave 套件"

3.2.4.3. PCMCIA

cardmgr 已不再管理 PC 卡。而是由核心模組管理 Cardbus 卡和其他子系統。所有必要的動作均由 hotplug 所執行。pcmcia 啟動程序檔已被移除,而且 cardctl 已取代成 pccardctl。若需詳細資訊,請檢視 /usr/share/doc/packages/pcmciautils/README.SUSE

3.2.4.4. 設定 .xinitrc 中程序間通訊的 D-BUS

許多應用程式現在必須依靠 D-BUS 來進行程序間通訊 (IPC)。呼叫 dbus-launch 可啟動 dbus-daemon。全系統 /etc/X11/xinit/xinitrc 會使用 dbus-launch 來啟動視窗管理員。

如果您有本地 ~/.xinitrc 檔案,您就必須跟著進行變更。否則如 f-spot、banshee、tomboy 或網路管理員 banshee 等應用程式都可能會失敗。請儲存舊的 ~/.xinitrc。然後使用以下指令,將新的樣板檔案複製到主目錄:

cp /etc/skel/.xinitrc.template ~/.xinitrc

最後,從儲存的 .xinitrc 新增自訂。

3.2.4.5. 重新命名的 NTP 相關檔案

為了顧及與 LSB (Linux Standard Base) 的相容性,大部分的組態檔和 init 程序檔都必須從 xntp 重新命名為 ntp。新的檔案名稱為:

/etc/slp.reg.d/ntp.reg

/etc/init.d/ntp

/etc/logrotate.d/ntp

/usr/sbin/rcntp

/etc/sysconfig/ntp

3.2.4.6. udev 精靈所處理的熱插拔事件

熱插拔事件現在已全部由 udev 精靈所處理 (udevd)。我們不再使用 /etc/hotplug.d/etc/dev.d 中的事件多工器。相反地,udevd 會根據其規則,直接呼叫熱插拔協助工具。udev 規則和協助工具是由 udev 和其他套件所提供。

3.2.4.7. TEI XSL 樣式表

/usr/share/xml/tei/stylesheet/rahtz/current 的新目錄配置下尋找 TEI XSL 樣式表 (tei-xsl-stylesheets)。例如,從這裡使用 base/p4/html/tei.xsl 以產生 HTML 輸出。如需更多資訊,請參閱 http://www.tei-c.org/Stylesheets/teic/

3.2.4.8. GNOME 應用程式的檔案系統變更通知

GNOME 應用程式必須依靠檔案系統變更通知的支援,才能正常運作。如果是使用僅限本地的檔案系統,請安裝 gamin 套件 (優先設定) 或執行 FAM 精靈。如果是使用遠端檔案系統,請在伺服器和用戶端上執行 FAM,並為 FAM 啟動的 PRC 呼叫開啟防火牆。

GNOME (gnome-vfs2 和 libgda) 包含了包裝函式,其會選擇 gamin 或 fam 來提供檔案系統變更通知:

  • 如果 FAM 精靈不在執行中,請優先選擇 gamin。(原因:Inotify 僅由 gamin 提供支援,而且在本地檔案系統中效率更高)。

  • 如果 FAM 精靈正在執行中,請優先選擇 FAM (原因:如果 FAM 正在執行中,您可能會需要遠端通知,而這只能由 FAM 提供)。

3.2.5. 從 10.0 到 10.1

請參閱「SUSE LINUX 10 中的已知問題及特殊功能」這篇文件,請造訪位於 http://portal.suse.com 的「支援資料庫」,使用關鍵字特殊功能來找出這份文件。

3.2.5.1. Apache 2.2

針對 Apache 2.2 版的 章 26, Apache HTTP 伺服器已完全改寫。此外,如需一般升級資訊,請造訪 http://httpd.apache.org/docs/2.2/upgrading.html;如需新功能的說明,請造訪 http://httpd.apache.org/docs/2.2/new_features_2_2.html

3.2.5.2. 啟動 FTP 伺服器 (vsftpd)

根據預設,xinetd 將不再啟動 vsftpd FTP 伺服器。它目前是獨立執行的精靈,因此您必須使用 YaST 執行期間編輯器來進行設定。

3.2.5.3. Firefox 1.5:URL 開啟指令

在 Firefox 1.5 中,應用程式開啟 Firefox 例項或視窗的方法已改變。這項新方法已有部分運用於舊版本,當時是透過包裝函式程序檔來實作這些行為。

如果您的應用程式不會使用 mozilla-xremote-clientfirefox -remote,您就不需要進行任何變更。另外,開啟 URL 的新指令是 firefox url,而且這個指令可以隨時執行,無論 Firefox 是否正在執行。如果 Firefox 正在執行,它會依照從其他應用程式開啟連結已設定的優先設定來執行動作。

透過指令行,您可以使用 firefox -new-window url firefox -new-tab url 來影響這項行為。